Back to Ganoksin | FAQ | Contact

Prodigy flex shaft not working out of the box


#1

So, I just got a prodigy flex shaft from Rio Grande and I plugged it all up and it doesn’t run at all. The cords are getting power but the motor is not powering on. I don’t know what’s going on. It’s connected properly. I’m just dumbfounded. Brushes seem to be fine. Am I missing something? The manual says turn the motor on and the petal on, but there are no power buttons on either piece


#2

@RioGrande has excellent customer support a great tech team. You should give them a call.


#3

I tried to call them today, but unfortunately, I guess they’re closed on the weekends. I was hoping to resolve it before Monday so I could work on my Christmas projects, but it looks like I’ll have to wait. I may look to see if the owners manual has a number I can call.


#4

To add to my original post, I was questioning my own lack of knowledge as to why it wasn’t working. Rio Grande is an amazing company, which I’ve come to know from my recent purchases from them. My post wasn’t to imply that they’re selling less than the best quality products in the industry.


#5

is there a power switch on the motor?? It is right underneath the handle
where you hang it up?..Gerry!

*Gerry Lewy *
Toronto.

  • (905) 886-5961 *

#6

Is there a power switch right ON the motor? It is located right beside, or
under the handle where you hand up the motor to the pole!!

*Gerry Lewy *
Toronto.

  • (905) 886-5961 *

#7

It doesn’t look like it. There’s a domed spot in the middle but It’s not a button. I looked all around the motor and it doesn’t appear that there’s a switch or a button. When my husband checked the power flow with his wiggy, there was power going through all cords. The power going to the back of the motor stopped right at the end of the motor, where it connects. So we were assuming there was an on/off switch


#8

I got it to work! I saw on the back of the motor, where the cord connects into it, a little black piece with a separate small piece that seemed to be movable. I originally pushed it in, thinking that was the on switch, but it didn’t turn it on. Then when I got home from work this morning, I decided to try pulling it out some. That seems to be the power switch, because now it works. I guess when it’s pushed in, it breaks the circuit, but when pulled out, it completes the circuit. Thank you all for your replies! I definitely appreciate it :slight_smile:


#9

Get this repaired right away; the wiring of that motor is a fire hazard. That little movable piece is merely part of the plastic grommet which protects the cord from being frayed by the metal housing. If pulling it out sends current to the motor and pushing it in stops it, then there is most likely a short in the power cord itself.
Do not delay. Unplug it and send it for replacement or repair.


#10

Hello “Kawaiidragon” that Prodigy flex shaft is made in China… now all you need is the best foot operated Rheostat in the Jewelry Industry & made in the USA by a Company that has been around Since 1930 LUCAS DENTAL … its called the #9 Lowboy… all metal, not plastic…at $49.00… can be seen in our Website: www.lucasdentalcompany.com thank you & Regards, Richard Lucas email: Lucadent@verizon.net


#11

I totally agree with what Elliot said. You’ve got a bad/intermittent connection in there.


#12

Does that machine have an “UL” or “Underwriters Approval” certificate on
the metal stamp somewhere?. Wrap it up and send it back to the supplier,
let them pay for the return shipping!!!..:>( Another note, cancel the CC
payment with your bank, if that was the way you paid for it!

*Gerry Lewy *
Toronto.

  • (905) 886-5961 *

#13

Agreed. Do not use this device. Shorts and or fires are a distinct
possibility.
Aaron


#14

I added a FlexShaft pedal to mine to assure it lasts and keeps up to speed


#15

No, there isn’t a UL certificate. I bought this through a leading jewelry supplier here in the US, so I don’t feel I need to cancel the charge through my bank. They’re a very reputable company that handles returns and exchanges on a professional scale. I can vouch that it’s not a shady type of situation where I feel like I might get scammed. I will call them tomorrow and arrange a replacement for faulty wiring.


#16

You have the same one? Did you have any similar issue when you got it, or did it start right up?


#17

In Canada, if any machine that is brought in and no UL. It isn’t allowed permitted for sales, period!
Even in the US, any electrical machine must be UL approved. It is upon your supplier to be made aware of this. I wouldn’t use it if I were you!
Gerry! On my Teaching iPhone!


#18

It started right up. Rio will replace yours that has the broken ring ASAP


#19

Oh awesome. I was wondering if they’d send the new one and allow me to send this one back with whatever box they ship it in and a return label. It would make things easier, I suppose. I guess I’ll see tomorrow when I call them.


#20

Good luck!
Btw…I have a flex shaft and the Prodigy. The prodigy with the FlexShaft
pedal feels no different from the Flexshaft