DTC800 Digital kiln help

Hi there,

I could really use some advice - I’ve got a digital kiln - DTC 800
(the bright orange kind, and it has a Grobet label on it). Its
casting time at Auburn Riverside High School, so I pulled her out of
storage and plugged her in. Immediately, a piercing sound and an
error message appeared (speciffically “ErrP”). Normally, you just
hit the “start” button, and it goes to “idle”, but when I pushed the
button, there was no response. I unplugged and replugged, pushed
other buttons, but there was no response, just the piercing noise
and the ErrP.

I downloaded the trouble shooter for this kiln from the web, and
although the “ErrP” is mentioned, the context is quite different.

The only other thing I tried was to change the fuse, but to no

Any suggestions? I’d REALLY appreciate it.

Thank you,
Wendy Woldenberg
Jewelry Instructor, A.R.H.S.


Mine always makes that piercing sound when I first plug it in, try
pressing ENTER. ( Sometimes I get that “ErrP” also but when I press
enter it immediately goes to “idle”)

If that does not work, do not hesitate to Call Grobet’s tech support

  • they are amazing -


I believe DTC 800 refers to the type of controller you have for your
kiln, rather than the make of the kiln itself. My kiln has a DTC 800C
controller with the Paragon label on it. My suspicious is that they’re
similar, although mine is probably 10 years old and may work slightly

Does your controller have a toggle switch? You may have to flip that
switch to ON to get the controller to recognize that you’re pressing
buttons. Mine has a toggle switch on the left side of the front panel
of the controller. Yours may not have it or may have it in a different

On my controller, ErrP means that there was a power outage that
caused the kiln to lose power. When I get the ErrP message, I press
the STOP button to get it to go to IDLE. This error message occurs
when the kiln is unplugged, which obviously yours has been since you
just received it.

The controller won’t recognize any buttons I press, unless the
toggle is set to the ON position, as mentioned above.

If these suggestions don’t work, you might try asking on the
Kilnforming board at www.warmglass.com for and help.

Hi Wendy Woldenberg, Jewelry Instructor, A.R.H.S.

ErrP means power failure (the machine was unplugged). We can supply
a copy of the DTC 800 manual if that would help. It may have more
info in it than what you downloaded from the web.

John Cranor
The Jewelry Equipment Dr.

Thank you for your response. I have actually had the kiln for 10
years, but I unplug and store it while not in a casting unit (very
small classroom). So, that was why it was so shocking when it didn’t
work (since it has been so reliable).

I tried moving the toggle switch, and doing everything the manual
said about power failure (which we didn’t have). The Electronics
teacher came by yesterday to check the various wires with an
altimeter, and it all checked out well. So, when we put it all back
together, I was totally surprised when it ACTUALLY WORKED!
Essentially, all we did was wiggle some wires around inside the
panel, and it seemed to do something. I’m not asking questions, just
bowing to some divine grace.

Thank you again for your response.